python coding test course, determining bipartite graphs

In this article, we will discuss the concept of Bipartite Graphs and the algorithmic problem for determining whether a graph is bipartite.
A bipartite graph is one that can be divided into two sets of nodes, and the key is to determine whether adjacent nodes belong to different sets.

Problem Description

We will solve the problem of determining whether a given graph, made up of vertices and edges, is bipartite.
Specifically, this problem will take the following input.

  • First line: The number of vertices n and the number of edges m are given, separated by a space.
  • Next m lines: Two vertices u and v connected by each edge are provided.

The output will be YES if the given graph is bipartite; otherwise, it will output NO.

Example Input 1

3 3
1 2
2 3
1 3

Example Output 1

NO

Example Input 2

3 2
1 2
2 3

Example Output 2

YES

Problem Solving Process

1. Understanding the Definition of a Bipartite Graph

A bipartite graph is one where, when each node is divided into two groups, no nodes within the same group are connected.
Such graphs can generally be identified through the possibility of bipartite coloring.

In other words, when coloring a node, the adjacent nodes should be colored with the opposite color, and if there are no nodes colored the same until the end, it is a bipartite graph.

2. Graph Representation Method

To represent the given graph, we will use an adjacency list. We maintain a list of vertices connected to each vertex.
In Python, we can easily construct the graph using a dictionary.

Python Code Example (Graph Construction)


def create_graph(n, edges):
    graph = {i: [] for i in range(1, n + 1)}
    for u, v in edges:
        graph[u].append(v)
        graph[v].append(u)
    return graph

3. Coloring Using BFS or DFS

We can use either the BFS or DFS algorithm to traverse the graph. We will use the BFS method to determine if the graph is bipartite.

The basic idea of BFS is to color the starting node with an arbitrary color and proceed to color all adjacent nodes with the opposite color.
If any adjacent node is already colored and matches the current color we are trying to color it with, then it is not a bipartite graph.

Python Code Example (BFS Coloring)


from collections import deque

def is_bipartite(graph, n):
    color = {}
    for node in range(1, n + 1):
        if node not in color:
            queue = deque([node])
            color[node] = 0  # Color the starting node

            while queue:
                current = queue.popleft()

                for neighbor in graph[current]:
                    if neighbor not in color:
                        color[neighbor] = 1 - color[current]  # Color with opposite color
                        queue.append(neighbor)
                    elif color[neighbor] == color[current]:
                        # If the same color, then it is not a bipartite graph
                        return False
    return True

4. Implementing the Entire Program

Now we will integrate the graph construction and the bipartite determination logic to complete the entire program.


def main():
    n, m = map(int, input().split())
    edges = [tuple(map(int, input().split())) for _ in range(m)]

    graph = create_graph(n, edges)
    
    if is_bipartite(graph, n):
        print("YES")
    else:
        print("NO")

if __name__ == "__main__":
    main()

Conclusion

In this article, we explored the concept of bipartite graphs and the algorithmic problem of determining them.
We explained an efficient method to identify bipartite graphs through BFS and examined a more practical approach using Python code examples.

We plan to cover various algorithm topics in the future, so please continue to stay tuned. Thank you!